【 Flutter 】Flutter を 基礎 から 学習 ( ライブラリ ) part202 便利なパッケージ

基礎 から 学ぶ Flutter 」という書籍で  学習 したことを ブログでアウトプットしていこうと思います。今回は ライブラリ ( part202 )です。

前回

【 Flutter 】Flutter を 基礎 から 学習 ( ライブラリ ) part201 便利なパッケージ

引き続き、ライブラリについて学びます。

便利なパッケージ

intl, intl_translation パッケージ

前回の続きになります。

MaterialAppウィジェットのsupportedLocalesプロパティにLocaleを記述します。

・・・とその前にpub getを忘れていたので実行することにしました。

すると・・・エラー!

D:\flutter\bin\flutter.bat --no-color pub get
Running "flutter pub get" in flutter_app...                     
Because intl_translation >=0.17.7 depends on intl >=0.15.3 <0.17.0 and every version of flutter_localizations from sdk depends on intl 0.17.0, intl_translation >=0.17.7 is incompatible with flutter_localizations from sdk.
So, because flutter_app depends on both flutter_localizations from sdk and intl_translation ^0.17.10+1, version solving failed.
pub get failed (1; So, because flutter_app depends on both flutter_localizations from sdk and intl_translation ^0.17.10+1, version solving failed.)
Process finished with exit code 1

同じ事象の型がいらっしゃいました。

【Flutter】intl_translationをインストールできなくなりました。 (teratail.com)

どうやらdependency_overridesセクションにintl anyを記述しないといけないようです。

修正してpub getしてみると、ワーニングは出力されましたが無事にインストールできました。

D:\flutter\bin\flutter.bat --no-color pub get
Running "flutter pub get" in flutter_app...                     
Warning: You are using these overridden dependencies:
! intl 0.17.0
Running "flutter pub get" in flutter_app...                         8.0s
Process finished with exit code 0

最後に

前回「昔は国際化対応」と呼んでいたきもする・・・と書きました。
なんとP276に「国際化対応」という文字が(笑
あえて使い分けをしているのかもしれませんが、多言語対応・国際化対応のどちらかに統一したらよいと思ました。

今日はここまで!

参考

【Flutter】intl_translationをインストールできなくなりました。 (teratail.com)

Getting Compile Error – pub get failed (1; ….